2018年11月18日 星期日

Node.js : 安裝指定版本的 firebase-tools

2018年11月18日 星期日
前幾天想更新 Google Firebase 空間中的檔案,執行 firebase deploy 後,居然無法上載檔案。後來將 firebase-tools 更新為最新版以後,更慘~連執行都不能執行。後來一陣亂搞後,連 node.js 都玩壞了。

其實主因還是自己常用的電腦是跑 Windows XP ,node.js 已經無法安裝最新版,連帶的 firebase-tools 也無法使用最新版。

今天把 node.js 重新安裝,順便記錄一下用 node.js nmp 如何安裝指定版本的 firebase-tools。例如想安裝 v4.1.0 的 firebase-tools ,就執行:

npm install -g firebase-tools@^4.1.0

哇~這樣子可以安裝舊版的 firebase-tools ,那在 Windows XP 可以再上載資料到 firebase server 了嗎?

並不是所有的故事都是以歡樂結束的,答案是:「不行!」。

0 意見:

張貼留言

 
© 2009. Design by Pocket